Application – Setup and Run MadeToPrint

The start dialog of MadeToPrint lists up all defined Output Jobs, which can be applied with a simple mouse click to the currently open Adobe InDesign document. A batch processing feature enables MadeToPrint Output Jobs to be applied to several InDesign documents in one go.

How to access and run MadeToPrint

MadeToPrint can be started from the “File” menu in InDesign.

Starting MadeToPrint for the first time, you will have the option to install sample MadeToPrint Output Jobs giving you an idea about how a Output Job looks like.

Furthermore, it  is possible to access MadeToPrint via the Plug-Ins menu from. There you can access the Edit Mode directly via MadeToPrint Printjobs; Define.... Moreover, you can directly run a Output Job that has already been created and is listed here.

Individual keyboard shortcuts can be defined to access MadeToPrint. The definition is done via InDesign menu Edit; Keyboard Shortcuts... In Product Area there is an entry axaio MadeToPrint.

The Run Mode

In InDesign, choosing the MadeToPrint entry from the File menu will activate the Run Mode. The Output Jobs or Job Sets which have been configured can be applied to the current document by clicking on the Run button.

Furthermore, the number of copies can be specified for print output and page ranges can be defined.

The mode of processing files or books can be chosen from the popup-menu:

  • Process current document: Carries out the selected Output Job/Job Set on the currently opened document.
  • Process all open documents: Carries out the selected Output Job/Job Set on all currently opened documents one after the other.
  • Process current book (for PostScript output only): Carries out the selected Output Job/Job Set on the currently opened book.
  • Process all books (for PostScript output only): Carries out the selected Output Job/Job Set on all currently opened books.
  • Process folder: Allows batch processing specific folders with all InDesign documents inside.

To create new or edit existing Output Jobs or Job Sets, click the Edit button.

MadeToPrint Edit Mode

This mode provides all tools to create and edit Output Jobs as well as the option to combine several existing Output Jobs into one Job Set in order to carry them out simultaneously.

The Edit Mode is divided into three parts. On the left you find a column listing up Output Jobs and Job Sets. The middle column lists up the different groups of options. The right area displays the options available for adjusting the selected Output Job.

The top buttons let you Create, Duplicate, Delete, Export and Import Output Jobs as well as Job Sets. Hence Output Jobs can be distributed in connection with Adobe InDesign Server.

In the lower left area you will find a dropdown menu. The name of the currently active configuration is shown here. The current configuration is displayed in Edit Mode. Via the dropdown menu, you can switch from the active to another configuration which has already been created.

MadeToPrint Configurations can be organised via the InDesign menu; Plug-Ins; MadeToPrint Configurations; Manage.... More on this in the manual in the chapter MadeToPrint Configuration

In the lower right area of the Edit Mode are three buttons, whose effect is universal. They are:

  • Save settings without closing box (Apply)
  • Return to the last saved version (Revert)
  • Save and close box (Close)

“General” Options

These options are available:

  • Name: For specifying a Output Job name.
  • Active: Untick the check box for disabling the Output Job within run mode.
  • Locked: Modifications to locked Output Jobs cannot be saved.
  • Rating: Output Jobs and Job Sets can be rated.
  • Comment: You may enter a comment to each Output Job, which is displayed in the Run dialog, when the Output Job is selected.

We recommend you to use the comment field to note a meaningful description of each Output Job. This description will also be shown in the representation of the list in Run Mode.

MadeToPrint Configuration

With the help of the MadeToPrint Configurations, the numerous tasks can be organised in a higher level. Multiple, independent Configurations can be created. A single Configuration can contain several Output Jobs, Job Sets and Auto Jobs. In Edit Mode, the active Configuration is at your disposal. A drop-down menu in Edit Mode allows you to switch between the Configurations in order to process them.

MadeToPrint Configurations can be organised via the InDesign menu; Plug-Ins; MadeToPrint Configurations; Manage.... If Configurations were already created, one of the existing configurations can be activated in the flyout menu. The currently active configuration is highlighted, here it is "Demo" and will be displayed in Edit Mode, when MadeToPrint is accessed.

New configurations can be created here. Existing configurations can be edited, duplicated, deleted, exported or imported.
In Edit, configurations can be renamed, a description can be added and the content information can be viewed.

“Output” Options

In the Output section, from the drop-down menu you can select if the Output Job is to apply to PostScript output on a printer or to file output. For file output the formats PostScript, EPS, PDF, PDF Interactive, JPEG, PNG, TIFF, IDML, EPUB und InDesign are available.

The entry No Output allows to Package or Preflight InDesign documents without creating file or print output.

The Summary field allows an overview of the current settings

Context-sensitive to the selected output type, you can use the Setup... button to access the Adobe InDesign dialog box for setting up the print, PostScript, EPS, PDF, PDF Interactive, JPEG, PNG, TIFF, EPUB and InDesign output.

MadeToPrint addresses the print and export dialogs of Adobe InDesign for configuring the output settings for printing, PostScript and EPS. For the PDF export, all export presets are made available in a pop-up menu.

If you are carrying out a JPEG export, you can make settings for the image scale and resolution.

axaio MadeToPrint:  JPEG Export Settings

“Distiller” Options

This option allows you to create PDF files via PostScript and Acrobat Distiller. The installation of Acrobat Distiller is required. After having defined the path to Acrobat Distiller, all Adobe PDF settings available for conversion in a popup menu.

Furthermore, you can keep or delete the PostScript and the log files.

Using Acrobat Distiller avoids problems with CID fonts in PDF files. Especially older RIPs can run into problems when trying to process CID fonts which are created when using the InDesign PDF export.

“File Name” Options

In this area, users can specify destination folders and file names for file output. MadeToPrint supplies a very flexible tool for rule-based creation of file names and destination folders. For print output, these options are not available.

File and folder names can be determined by tokens (variables). A description on how to use these variables can be found in the Token Help.

How to Define Destination Folders

  • To save output files next to the current InDesign document, activate the check box Use path of current document/book.
  • Optionally, click the Choose... button to select a destination folder.
  • You can define a fix path or define rules that determine the destination path during Output Job run time. To define such a rule you can choose between various tokens.
  • A preview of the path will be displayed in case the token is used properly.

How to define file names

  • To use the document name for the output file please activate the check box Use name of current document/book.
  • A wide range of tokens is available for flexible output file naming. In connection with the single page output option, the token “DOCUMENTNAME()” can be combined with the token “PAGENUMBER()” to add the respective page number to the file name.
  • The check box Overwrite Output File defines whether the existing files are to be overwritten or to be indexed.
  • The check box Do not create destination folder prevents output folders from being created dynamically, i.e. if the output folder does not already exist, this is an error.

Token Sequences/Token Editor

Even complex rules can be set up, edited and administrated conveniently via the Token Editor. The list of Token Sequences is available as a dropdown menu wherever Tokens are used in MadeToPrint.

Press the Edit Token Sequences button to open up the Token Editor with the list of all created Token Sequences. For creating or editing Token Sequences, all Tokens are available. Use the preview to check your settings.

 Token Editor

The use of tokens is not restricted to a single entry. You can create token sequences with a combination of different tokens and also include static text. The Token Editor of MadeToPrint (Button: Edit Token Sequences) allows you to create, check and save token sequences in order to use them in different settings.

“Page” Option (Single Page Output)

In this area, you can predefine the output of documents as single pages. Enable the checkbox for a single page output. By default, this checkbox is not activated, for EPS output it is generally activated.

Show Page Box

By using the option Show Page Box, users can create lines around the document or the document content, e.g. cropmarks can connected to a frame. position, color, width and opacity of these pages boxes can be adjusted flexibly.

“Layer” Options

MadeToPrint is able to manage layers in Adobe InDesign documents flexibly. Using the Layer option, document layers can be output in different combinations:

  • Output all visible layers (WYSIWYG)
  • Output all layers (output all existing layers on one page)
  • Output every visible layer separately (output every visible layer on a separate page)
  • Output every layer separately (output every existing layer on a separate page)
  • Output layer combination (output fix layers in combination with the variable layers of the document)

The three output methods below are available in interaction with “MadeForLayers” (see Chapter 3):

  • Output default layer view (output original layer view of the document that can be defined via the UI of “MadeForLayers”)
  • Output all layer views separately (output all “Layer Views” separately that can be defined via the UI of “MadeForLayers”)
  • Output layer views by name (define the name of the layer view to be used for output)

The option Output layer combination enables users to select layers and combine them to different output combinations. Certain layers can be kept, others can be discarded.

For the last three layer modes, you have the following option:

  • Raise error when a layer is not in the document.

Example: Multi-lingual document

Your document contains the layers background and pictures as fix layers. Additional layers are assigned to text in different languages (per document layer).

How do I set up my Output Job?

  • The category Fix Layers contains layers for background and pictures
  • The category Per Document Layers contains the layers text_fr, text_en, text_de

The result will be three output files each containing a different language version.

To transfer the names of the layers into the file names, you can use the two token Layer name and Layer number.

“Infobar” Options

The Infobar can be added to printouts as well as to PS files. You can include information in three size variable fields (left, center, right), tokens are entirely supported. A preview function shows the result to be expected. To prevent the infobar from overlapping with document content, the document can be moved (to the top, the bottom, the right or the left side of the document) and scaled.

The width of the three possible infobar areas can be defined using any of the following units of measurement: point, millimeter, inch or percent.

“Printjob Name” Options

The dialog box for Printjob Name allows to setup a naming convention for internal PostScript names. By activating the checkbox Printjob Name for Print Queue, users can specify how the name should look like.

The job name can either be the same as the output file or be determined through tokens. These can be used to evaluate information like date, time, document name, pagenumber, pagelabel etc. dynamically.

A description on how to use the token (variables) can be found in the Token Help.

“PostScript Expert” Options

In this area, PostScript output can be extended via PostScript snippets, to be selected from pull-down menus. As the name suggests, PostScript Expert is intended for users who are familiar with PostScript.

An integrated editor allows to create, modify and save PostScript snippets.

“Image Info” Options

In this area you can set up MadeToPrint in a way that it will print a patch containing the file path of linked assets onto each of them. It can optionally also include the scaling values (horizontal and vertical scaling) and page label. You can choose if that patch will be applied at top, middle or bottom of each image and choose the font to use.

The option "print grey area instead of images linked to the document" will replace the actual image with a grey area. In conjunction with the "Print path of external file on the image" it offers a variety of options.

This area only applies to linked assets (those visible in the link panel).

Font size and font type are adjustable. The path information can be printed on the respective image or instead of it - to be controlled via the checkbox Print grey area instead of images.

“Preflight” Options

MadeToPrint offers options to preflight documents, and check for missing fonts and images.

You can use the preflight functions of MadeToPrint or you can access InDesign’s Live Preflight engine.

It is possible to update modified and missing links (images) and to activate project specific fonts on the fly. MadeToPrint searches for missing fonts and images in folders and subfolders next to the InDesign file or optionally starts searching from the parent folder.

MadeToPrint places the missing fonts in the temporary Fonts folder, which is located in the Adobe InDesign application folder.

Especially when using the Auto version of MadeToPrint, this feature is very helpful to streamline your workflow.

InDesign Preflight  – this option lets InDesign check for missing fonts and links when opening the file.

Optionally, MadeToPrint can activate project-specific fonts, update modified images, and search for missing images. MadeToPrint can also search for fonts and images in the folders that are adjacent to the InDesign document (fig. to the left). Optionally, MadeToPrint can start the search in the parent folder (fig. to the right). In addition you can define to search in a particular folder outside of the package.

The automatic activation of fonts and updating of images is particularly important in auto mode and helps to optimize the workflow and avoid manual steps.

To use InDesign Live Preflight, activate the “InDesign Preflight” checkbox. You can access preflight profiles here (profiles defined in the document itself and/or test profiles that you created in InDesign).

axaio MadeToPrint

Action in case of error  – using this popup menu, users can define how to proceed in case of preflight errors.

  • Do not process document (skips the incorrect file and opens the next document)
  • Halt processing and show error (Stops processing. An error message displays detected problems)
  • Process document nevertheless (outputs the file anyway)

Save report file  MadeToPrint can create report files, which will be placed next to the InDesign file. Report files can be created.

  • In case of error
  • Always or Never

Imposition option

With the Imposition function, you can output fully imposed PDF files. The preconfigured imposition schemes cover all common imposition tasks.

To set up a Output Job (e.g. for imposition of business cards, double-sided on one page) create a new Output Job and enter a name under General (here: Business Card).

In the Output area, as target select File (PDF). The Imposition function is not available for PostScript printing. If PostScript exists, you can use the Distiller to create a PDF file.

Attention: For smooth operation, ensure that Single Page Output is deactivated in the Page area.

Then, under Imposition activate the Imposition function and compile the required imposition scheme with the entries under the Runlist and Sheet configuration categories.

Here ensure that the number of pages in both categories matches.

For the imposition of business cards, the specifications under Runlist: 8 business cards, double-sided and Sheet configuration: A4, 8 business cards are suitable.

If the supplied imposition scheme does not cover a task, you can adjust (knowledge of programming required) the settings file in a Script editor. The files are located in the directory Adobe InDesign.../Plug-ins/axaio software/pdfToolbox/var/Actions/Impose.

Further information on how to build imposing settings can be found in the pdfToolbox manual at https://help.callassoftware.com/m/pdftoolbox/l/653051-building-blocks-of-an-impose-configuration.

You can also contact us at support@axaio.com.

The configuration is now complete. Now save the Output Job.

In the MadeToPrint Run Mode the Business Card imposition specification is now ready for processing layout documents.

axaio MadeToPrint

Flexible export customization with “Parameter Overrides”

It is often necessary to customize individual parameters in an existing Output Job. If you want to change only a single variable and avoid having to create a new Output Job, you can use the “Parameter Overrides” option.

In the “Parameter Overrides” area of the MadeToPrint settings, users can enable the function through the checkbox.

The “Edit Parameter Overrides” button takes you to the extensive setting options for customizing parameters.

In the “Edit Parameter Overrides” dialog, you can customize individual output options. This includes default values for the Color space, Bleed marks and Image resolution areas.

The complete list is displayed here.

If enabled, the “Ask” checkbox lets you enter individual values at runtime. So you can apply various output parameters for different documents “on-the-fly”.

In the Job Set, the parameters can be configured dynamically as needed: Manually in the MadeToPrint standard version and automatically in the Auto and Server version, by controlling with a job ticket or workflow system.

When entering numeric values for lenght (e.g. bleed distance), the value is recognized as point (pt). You can also provide a unit (e.g. "3mm").

Extended PDF test with “PDF Post-Process”

While MadeToPrint checks InDesign files for errors with the Preflight function presented above, with the “PDF Post Process” option PDF files can be checked in connection with the output for requirements defined before.

In the “PDF Post Process” window, a Output Job is released for the subsequent test by clicking “Enable PDF Post Process”.

Some test profiles are already preconfigured, for example for digital printing (black-white and color) and for online publishing of PDF documents.

If required, a text report can be created in various formats. You can also specify if you want errors in the PDF to be ignored by MadeToPrint.

With the Manage Profiles button, the user can add more profiles that can be created using the callas pdfToolbox.

Another option is to open the PDF generated by MadeToPrint in your default PDF viewer right after the finishing of the export.

“Package” Options

Enable this checkbox to create packages of InDesign documents. Click the Choose... button to select the destination folder. Once again, tokens can be used in order to name packages and package files flexibly and according to individual workflow demands.

Optionally, you can select whether fonts and external graphics should be copied and whether graphics should be updated. You also decide, whether to include hidden layers and whether RGB warnings can be ignored. You can also create a report file and include an IDML and PDF.

The Preflight and Package functions can also be configured for Output Jobs without print or file output by selecting "No Output" in the Output section.

“Batch+Script” Option

MadeToPrint offers a batch processing functionality, to be used for outputting all InDesign documents located in a specific folder.

Preprocess Script File or Postprocess Script File – additionally you can run scripts from within MadeToPrint before or after output. Available script formats are: JavaScript, AppleScript (Mac), VisualBasic Script, JavaScript and Batch files (Windows).

Each preprocess script can be run once for the Output Job (default), or – in single page/layer output – for each seperate layer or page.

If the script returns a string beginning with “error”, MadeToPrint will recognize the error and stop exporting the document. The text behind “error” is defined as error message in Auto mode (see sample).

Open all documents before processing.

The advantage of this option: The batch process will not be interrupted by upcoming error messages. You can confirm error messages before processing.

Completely process each document one after the other – defines that documents are opened and processed one after the other.

After a batch processing job has been finished you will find a report file inside the selected batch folder. This report lists processed files as well as files that have not been. In case the preflight option had been activated, error reports will be placed next to the respective InDesign file.

Sample for Script

function doStuff()
{
try {
 //[...]
} catch(error) {
 return "Error"+error;
}
return "OK";
}
doStuff();

Publishing Systems: Adapter Mode

The Adapter mode can be activated to use MadeToPrint in connection with old K4 publishing system (up to K4 version 5.9). For modern versions this option is obsolete.

If the check box is ticked and the publishing system is selected on the context sensitive pull down menu, four options are available:

Before processing: Updating contents (text and links).

After processing: The standard option is No action, it is also possible to select Check in layout or Cancel check out layout

Compiling a new Job Set

To execute several Output Jobs together, MadeToPrint offers an option for compiling. You can create a new Job Set by using the icon shown below.

MadeToPrint allows for combining several Output Jobs into one Job Set. Job Sets can also be used in batch-processing mode.

Similar to Output Jobs, Job Sets should be annotated with a name. Also, they can be set to Active and Locked and be completed with a description.

Under Referenced Output Jobs a popup menu lists up all available Output Jobs, by using the buttons Add and Remove Output Jobs can be appended to or deleted from the Job Set.

Newly created Job Sets are then listed in Run Mode.

The Run Mode with completed Output Jobs and Job Sets

The Run Mode lists up all active MadeToPrint Output Jobs and Job Sets.

If you select a Output Job or a Job Set in Run Mode, the description will appear as a comment in the field below.

The first ten Output Jobs can also be run via Keyboard Shortcuts. The order can be chosen by setting a higher rating.

Administrate Output Jobs in workgroups

Output Jobs can be shared with or distributed for other MadeToPrint users.

Creating standard-settings

All Output Jobs and Job Sets being created are saved automatically to the following locations:

Windows: C:\Users\admin\AppData\Roaming\axaio software\Adobe InDesign X\MadeToPrint Plug-In\Preferences

Mac OS X: Macintosh HD/User/Library/Preferences/axaio software/Adobe InDesign X/MadeToPrint Plug-In/Preferences

The X stands for the InDesign Version. „InDesign CC 2018“ is "Adobe InDesign 13". If you use "InDesign CC 2021", the folder is "Adobe InDesign 16"

Following these paths, you will find a number of folders and files:

  • Preferences
  • PostScript Expert
  • Environment
  • Logfiles

Workgroup settings

In order to make the Output Jobs and Job Sets available to every user on a workstation, they only have to be copied to another location:

Windows: C:\ProgramData\axaio software\Adobe InDesign X\MadeToPrint Plug-In\Preferences

Mac OS X: Macintosh HD/Library/Preferences/axaio software/Adobe InDesign X/MadeToPrint Plug-In/Preferences

Running MadeToPrint with the settings saved to the all-user directories will prevent Output Jobs and Job Sets from being modified. This is visualized by a lock behind every Output Job or Job Set within the Run Mode.

0 Comments

Add your comment

E-Mail me when someone replies to this comment